Excel (VBA): Formeln aktualisieren nicht

2016-07-08 von admin

Beim Arbeiten mit MS Excel hat plötzlich die Aktualisierung der Formeln nicht mehr funktioniert. Folgende Schritte haben Abhilfe verschafft:

1. Auf den Reiter „Formeln“ klicken.

excel_formel_01

2. Den Eintrag „Berechnungsoptionen“ wählen und die Option „Automatisch“ setzen.

excel_formel_02

Fertig :)

Kategorie: IT Schlagwörter: , , , , , ,

Excel (VBA): Zellen in Excel runterziehen funktioniert nicht

2014-03-01 von admin

Heute hatte ich den Fall, dass in MS Excel 2007 das ziehen von Formel und Format übertragen nicht mehr funktioniert hat.

Nach kurzer Recherche war die Lösung gefunden.

  1. Auf die Microsoft Office-Schaltfläche  ZA010077102 Klicken.
  2. Dann auf Excel-Optionen Klicken.
  3. Daraufhin auf Erweitert.
  4. Und zu guter Letzt, im Bereich „Optionen bearbeiten“ das Kontrollkästchen „Ausfüllkästchen und Drag-and-Drop von Zellen aktivieren“ setzen.

Excel_Optionen

 

Danach funktioniert alles wieder wie gewohnt. Der Unterschied ist auch optisch sichtbar.

 

Deaktiviert Aktiviert
Excel_Optionen1 Excel_Optionen2
Kategorie: IT Schlagwörter: , , , , , ,

Excel (VBA): Wenn Abfrage mit Uhrzeiten

2013-10-28 von admin

Aus der Reihe kleine MS Excel Aufgaben für zwischendurch. Ich habe eine Spalte (A) mit verschiedenen Uhrzeiten. Ich wollte herausfinden, welche Werte davon kleiner als 07:00 Uhr sind.

 

Excel_Uhrzeit

 

Folgende Formel habe ich erstellt:

=WENN(TEXT(A2;"HH:MM")<TEXT("07:00";"HH:MM"); "Ja"; "Nein")

 

Hier eine Erläuterung der einzelnen Funktionen.

Die Funktion TEXT wandelt einen numerischer Wert in Text um. Dabei wird das Format der Uhrzeit mit HH:MM angegeben.

TEXT(A2;"HH:MM")

Dieser Zwischenschritt ist wichtig, da ein direkter Vergleich über die WENN Funktion zu einem falschen Ergebnis führt. Durch die Anpassung des Formats ist ein Vergleich möglich.
 
Die Funktion WENN vergleicht zwei Werte und gibt einen definierten Wert zurück.

=WENN(1<2; "Ja"; "Nein")

Wenn eins kleiner zwei, dann wird der Wert „Ja“ angezeigt, andernfalls der Wert „Nein“.

 

Kategorie: IT Schlagwörter: , , , , , ,

Excel (VBA): Summe bis aktueller Monat

2012-05-07 von admin

Vor ein paar Tagen hatte ich eine nette Aufgabe mit MS Excel zu lösen. Folgende Ausgangssituation, ich benötige die Summe der Werte in der Spalte B. Alle Monate die noch nicht begonnen haben, beinhalten einen negativen Wert. Diese möchte ich explizit aus der Summe ausschließen.

Kurz gesagt, ich benötige die Summe der Monate die kleiner gleich dem aktuellem Monat sind.

 

Folgende Formel kam dabei zustande:

=SUMME(B1:INDIREKT(ADRESSE(MONAT(HEUTE());2)))

 

Hier eine Erläuterung der einzelnen Funktionen.

Die Funktion Heute gibt den aktuellen Tag aus.

HEUTE()

Die Funktion Monat gibt den aktuellen Monat aus. Als Übergabeparameter wird ein Zahl (1-12) oder ein Datum benötigt.

MONAT(HEUTE())

Die Funktion Adresse gibt die Adresse der Spalte/Zeile aus.

ADRESSE(MONAT(HEUTE());2))

Die 2 ist die Spalte B.

Es wird der Wert „$B$5“  geliefert.  Eigentlich wären wir hier fertig. Folgende Funktion

Summe(B1; ADRESSE(MONAT(HEUTE());2)))

funktioniert so aber nicht. Die Funktion Summe benötigt immer einen von und bis Wert und versteht den variablen bis Wert nicht.

Mit der Formel Indirekt lässt sich dies umgehen. Hiermit lässt sich der Bezug ändern, ohne die Formel zu ändern.

INDIREKT(ADRESSE(MONAT(HEUTE());2))

Jetzt noch die Summenformel dazu und wir sind fertig. :)

 

Kategorie: IT Schlagwörter: , , , , , ,