Excel (VBA): Summewenns mit Datum

2014-03-02 von admin

Mit der Formel „Summewenn“ ist es möglich, Werte in einem Bereich zu addieren, wenn diese den angegebenen Kriterien entsprechen. Folgende Tabelle soll zur Veranschaulichung dienen:

Datenbasis

Interessant wäre jetzt herauszufinden, welcher Betrag je Kategorie angefallen ist.

SummeWenn

Hierfür kann die Formel „Summewenn“ verwendet werden.

SUMMEWENN(Bereich; Suchkriterium; Bereich für die Summe)

Das erste Attribut „Bereich“ legt fest, wo nach dem „Suchkriterium“ gesucht werden soll. Das „Suchkriterium“ ist die Einschränkung für die Summenberechnung (Bereich für die Summe). In diesem Beispiel sieht die Formel für die Summe der Beschaffung wie folgt aus:

=SUMMEWENN(A2:A10;E20;C2:C10)

 

Jetzt wäre noch eine Aufschlüsselung je Monat ganz nützlich. Ein weiteres Suchkriterium ist zwar möglich, aber gestaltet sich etwas umständlich. Deshalb gibt es seit MS Office 2007 die Formel „Summewenns„. Hier wurden die Suchkriterien erweitert und es sind mehrere Bedingungen für eine Summenbildung einstellbar.

Als erstes wird eine Hilfsspalte (D) benötigt, in der aus dem Datum der aktuelle Monat dargestellt wird.

Hilfsspalte

Mit der Formel Monat lässt sich das schnell bewerkstelligen.

=MONAT(B2)

Danach kann es dann los gehen.

SummeWenns

Die Reihenfolge der Attribute ist leicht verändert. Das erste Attribut wird für die Summenberechnung benötigt, danach folgt das erste Suchkriterium und der dazugehörige Bereich mit der Option weitere Attribute anzugeben.

SUMMEWENNS(Bereich für die Summe; Suchkriterium 1; Bereich 1, Suchkriterium 2; Bereich 2)

Für die Berechnung der Summe aller Werte der Beschaffung für den Monat Januar ergibt sich folgende Formel:

=SUMMEWENNS(C2:C10;A2:A10;H20;D2:D10;I19)

Zum besseren Nachvollziehen gibt es die Beispieldatei zum Download.

 

Kategorie: IT Schlagwörter: , , , , , , , ,