Excel (VBA): Summe nur negativer oder positiver Werte

2014-10-06 von admin

Mit MS Excel ist es mit der Funktion „SUMME“ möglich, die Summe einer Liste von Werten oder einem Wertebereich zu ermitteln. In der Zeile 7 befindet sich ein Beispiel für die Anwendung der Funktion mit einem Wertebereich.

Funktion Summe

=SUMME(B1:B6)

Für die Ermittlung der Summe aller negativen oder positiven Werte wird eine andere Funktion benötigt.

Summe_neg_pos

Eine sehr einfache Möglichkeit ist die Verwendung der Funktion „SUMMEWENN“.

Summewenn für negative Werte

=SUMMEWENN(B1:B6;"<0")

Der erste Parameter „B1:B6“ legt den Bereich für die Werte, die dem Suchkriterium entsprechen, fest und definiert den Bereich aller Werte, die summiert werden sollen. Der zweite Parameter „<0“ bestimmt das Suchkriterium, in diesem Fall, alle Werte kleiner null.

Summewenn für positive Werte

=SUMMEWENN(B1:B6;">0")

Für die Summe aller positiven Werte muss lediglich das Suchkriterium „>0“ angepasst werden.

 

Die Beispieldatei zum Download.

Kategorie: IT Schlagwörter: , , , , ,